Organization Service Login failures

Major incident Security and Authorization Organization Services
2020-09-02 16:48 EST · 33 minutes, 40 seconds

Updates

Resolved

The issues has been resolved and users should be able to login now without issue. Please contact support if you have any issues.

September 2, 2020 · 17:22 EST
Investigating

We are investigating an error being shown when logging into our Organization service.

September 2, 2020 · 16:50 EST

← Back